<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>&#039;Spirit of the North&#039; Review (Nintendo Switch)</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="http://fanfest.com/xmlrpc.php" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
var gtm4wp_datalayer_name="dataLayer";var dataLayer=dataLayer||[];
//]]></script>
<meta property="og:image" content="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04.jpg" /><link rel="icon" type="image/png" href="http://52.206.29.228/wp-content/uploads/2018/11/fan-fest-favicon.jpg">

<meta name="description" content="Spirit of the North, created by Infuse Studio and published by Merge Games, is a thought-provoking, albeit short, adventure." />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="http://fanfest.com/spirit-of-the-north-review-nintendo-switch/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#039;Spirit of the North&#039; Review (Nintendo Switch)" />
<meta property="og:description" content="Spirit of the North, created by Infuse Studio and published by Merge Games, is a thought-provoking, albeit short, adventure." />
<meta property="og:url" content="http://fanfest.com/spirit-of-the-north-review-nintendo-switch/" />
<meta property="og:site_name" content="Fan Fest | For Fans, By Fans" />
<meta property="article:tag" content="gaming" />
<meta property="article:tag" content="infuse studio" />
<meta property="article:tag" content="Journey" />
<meta property="article:tag" content="merge games" />
<meta property="article:tag" content="puzzle" />
<meta property="article:tag" content="review" />
<meta property="article:tag" content="spirit of the north" />
<meta property="article:tag" content="video games" />
<meta property="article:tag" content="walking sim" />
<meta property="article:section" content="Reviews" />
<meta property="article:published_time" content="2020-05-07T14:01:26+00:00" />
<meta property="og:image" content="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04.jpg" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Spirit of the North, created by Infuse Studio and published by Merge Games, is a thought-provoking, albeit short, adventure." />
<meta name="twitter:title" content="&#039;Spirit of the North&#039; Review (Nintendo Switch)" />
<meta name="twitter:image" content="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://fanfest.com/#website","url":"http://fanfest.com/","name":"Fan Fest | For Fans, By Fans","inLanguage":"en-US","description":"Get the Latest News for All Things Sci-Fi, Comic, Pop Culture and Geek!","potentialAction":{"@type":"SearchAction","target":"http://fanfest.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://fanfest.com/spirit-of-the-north-review-nintendo-switch/#primaryimage","inLanguage":"en-US","url":"http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04.jpg","width":1920,"height":1080},{"@type":"WebPage","@id":"http://fanfest.com/spirit-of-the-north-review-nintendo-switch/#webpage","url":"http://fanfest.com/spirit-of-the-north-review-nintendo-switch/","name":"&#039;Spirit of the North&#039; Review (Nintendo Switch)","isPartOf":{"@id":"http://fanfest.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"http://fanfest.com/spirit-of-the-north-review-nintendo-switch/#primaryimage"},"datePublished":"2020-05-07T14:01:26+00:00","dateModified":"2020-05-07T14:01:26+00:00","author":{"@id":"http://fanfest.com/#/schema/person/62eb9a7e6fd3dea81160e6d6444c41e4"},"description":"Spirit of the North, created by Infuse Studio and published by Merge Games, is a thought-provoking, albeit short, adventure."},{"@type":["Person"],"@id":"http://fanfest.com/#/schema/person/62eb9a7e6fd3dea81160e6d6444c41e4","name":"Richard Allen","image":{"@type":"ImageObject","@id":"http://fanfest.com/#authorlogo","inLanguage":"en-US","url":"http://0.gravatar.com/avatar/3e0c6bed98e8c3ec70735501bdbde2ea?s=96&d=mm&r=g","caption":"Richard Allen"},"description":"Richard Allen is a freelance writer and contributing editor for various publications. When he's not writing about video games on FanFest.com you can find him on Broadway World or in Graffiti Magazine. He can be contacted via email at richard@52.206.29.228 or richardallenwrites@gmail.com. You can visit his website at facebook.com/richardallenwrites","sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Fan Fest | For Fans, By Fans &raquo; Feed" href="http://fanfest.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fan Fest | For Fans, By Fans &raquo; Comments Feed" href="http://fanfest.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fan Fest | For Fans, By Fans &raquo; &#8216;Spirit of the North&#8217; Review (Nintendo Switch) Comments Feed" href="http://fanfest.com/spirit-of-the-north-review-nintendo-switch/feed/" />
<script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/fanfest.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.3"}};!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bingo_ruby_plugin_style-css' href='http://fanfest.com/wp-content/plugins/bingo-ruby-core/assets/style.css,qver=1.6.pagespeed.ce.8lOiUZYyuA.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='http://fanfest.com/wp-includes/css/dist/block-library/style.min.css,qver=5.3.3.pagespeed.ce.nu3cUbC0ol.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='http://fanfest.com/wp-content/plugins/td-composer/td-multi-purpose/style.css,qver=b84e3fe0e71a6db065c5ace64f57167f.pagespeed.ce.eUDoedmib-.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href="https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.7.4" type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='http://fanfest.com/wp-content/themes/Newspaper-tf/Newspaper/A.style.css,qver=9.7.4.pagespeed.cf.bTd_FTkOPD.css' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='js_composer_front-css' href='http://fanfest.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css,qver=4.11.2.1.pagespeed.ce.dVJKN7H9-p.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='http://fanfest.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css,qver=b84e3fe0e71a6db065c5ace64f57167f.pagespeed.ce.sSiCWjnk12.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css' href='http://fanfest.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/magazine/A.demo_style.css,qver=9.7.4.pagespeed.cf.vWly83R7MA.css' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css' href='http://fanfest.com/wp-content/plugins/td-cloud-library/assets/css/A.tdb_less_front.css,qver=388b2d8ea1192f4a22a4fef9c5911ef0.pagespeed.cf.m665_FHp4I.css' type='text/css' media='all' />
<script type='text/javascript' src='http://fanfest.com/wp-includes/js/jquery/jquery.js,qver=1.12.4-wp.pagespeed.jm.gp20iU5FlU.js'></script>
<script type='text/javascript' src='http://fanfest.com/wp-includes/js/jquery/jquery-migrate.min.js,qver=1.4.1.pagespeed.jm.C2obERNcWh.js'></script>
<link rel='https://api.w.org/' href='http://fanfest.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://fanfest.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://fanfest.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.3" />
<link rel='shortlink' href='http://fanfest.com/?p=150467' />
<link rel="alternate" type="application/json+oembed" href="http://fanfest.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ffanfest.com%2Fspirit-of-the-north-review-nintendo-switch%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://fanfest.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ffanfest.com%2Fspirit-of-the-north-review-nintendo-switch%2F&#038;format=xml" />
<meta name="google-site-verification" content="n7aotiJFFoBzbzCuf53EUTNwWCrS9a3UgQ-uItnEKmw" />
<meta name='ir-site-verification-token' value='2004671' />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
var dataLayer_content={"pagePostType":"post","pagePostType2":"single-post","pageCategory":["reviews","video-games"]};dataLayer.push(dataLayer_content);
//]]></script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-N5LZC46');
//]]></script>

<!--[if lt IE 9]><script src="http://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>window.tdb_globals={"wpRestNonce":"278090f978","wpRestUrl":"http:\/\/fanfest.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script>
<script>window.tdwGlobal={"adminUrl":"http:\/\/fanfest.com\/wp-admin\/","wpRestNonce":"278090f978","wpRestUrl":"http:\/\/fanfest.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};</script>
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress." />
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://fanfest.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://fanfest.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-65281966-2','auto');ga('send','pageview');</script>
<script>var trackOutboundLink=function(url){ga('send','event','outbound','click',url,{'transport':'beacon','hitCallback':function(){document.location=url;}});}</script>

<script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init','496263363914918');fbq('track',"PageView");</script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=496263363914918&ev=PageView&noscript=1"/></noscript>


<script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init','801210429981178');fbq('track',"PageView");</script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=801210429981178&ev=PageView&noscript=1"/></noscript>


<script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init','1577730285878022');fbq('track',"PageView");</script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1577730285878022&ev=PageView&noscript=1"/></noscript>

<meta name="google-site-verification" content="uEm9b82iAxmanjrlzv2VUxrIEE6EDW7xE2_3GYmDg7U" />

<script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}if(navigator.userAgent.indexOf("Edge")>-1){htmlTag.className+=' ieEdge';}if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var tds_general_modal_image="yes";var tdc_is_installed="yes";var td_ajax_url="http:\/\/fanfest.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=9.7.4";var td_get_template_directory_uri="http:\/\/fanfest.com\/wp-content\/plugins\/td-composer\/legacy\/common";var tds_snap_menu="snap";var tds_logo_on_sticky="show";var tds_header_style="";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#22abe3";var tds_smart_sidebar="";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var tdBlockNonce="b13381adbc";var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};var td_ad_background_click_link="";var td_ad_background_click_target="";</script>

<style>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</style>
<link rel="icon" href="http://fanfest.com/wp-content/uploads/2018/11/cropped-fan-fest-favicon-32x32.jpg.pagespeed.ce.P_E1A1BCmH.jpg" sizes="32x32" />
<link rel="icon" href="http://fanfest.com/wp-content/uploads/2018/11/cropped-fan-fest-favicon-192x192.jpg.pagespeed.ce.hAGE_53ql4.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://fanfest.com/wp-content/uploads/2018/11/cropped-fan-fest-favicon-180x180.jpg.pagespeed.ce.8a1b5sJfra.jpg" />
<meta name="msapplication-TileImage" content="http://fanfest.com/wp-content/uploads/2018/11/cropped-fan-fest-favicon-270x270.jpg" />

<style>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</style>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> <style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-150467 single-format-standard spirit-of-the-north-review-nintendo-switch global-block-template-1 td-magazine wpb-js-composer js-comp-ver-4.11.2.1 vc_responsive td-full-layout ">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N5LZC46" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<br style="display:none;" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/FanFestNews" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/fanfestnews/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/FanFestNews" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-footer-container"><ul id="menu-footer" class="td-mobile-main-menu"><li id="menu-item-123226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-123226"><a href="http://fanfest.com/">Home</a></li>
<li id="menu-item-10504" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10504"><a href="http://fanfest.com/category/movies/">Movies<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-123303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-123303"><a href="http://52.206.29.228/tag/dc/">DC<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-123306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-123306"><a href="http://52.206.29.228/tag/aquaman/">Aquaman</a></li>
<li id="menu-item-123305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-123305"><a href="http://52.206.29.228/tag/shazam/">SHAZAM!</a></li>
<li id="menu-item-123307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-123307"><a href="http://52.206.29.228/tag/wonder-woman/">Wonder Woman 1984</a></li>
</ul>
</li>
<li id="menu-item-105505" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-105505"><a href="http://52.206.29.228/tag/disney/">Disney<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-121765" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121765"><a href="http://52.206.29.228/tag/dumbo">Dumbo</a></li>
<li id="menu-item-121764" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121764"><a href="http://52.206.29.228/tag/mary-poppins">Mary Poppins Returns</a></li>
<li id="menu-item-105506" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105506"><a href="http://52.206.29.228/tag/ralph-breaks-the-internet/">Ralph Breaks The Internet</a></li>
<li id="menu-item-123857" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-123857"><a href="http://52.206.29.228/tag/the-lion-king/">The Lion King</a></li>
</ul>
</li>
<li id="menu-item-123302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-123302"><a href="http://52.206.29.228/tag/harry-potter/">Wizarding World of Harry Potter<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-105504" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105504"><a href="http://52.206.29.228/tag/fantastic-beasts-the-crimes-of-grindelwald/">Fantastic Beasts: The Crimes of Grindelwald</a></li>
</ul>
</li>
<li id="menu-item-105501" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-105501"><a href="http://52.206.29.228/tag/marvel/">Marvel<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-121760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121760"><a href="http://52.206.29.228/tag/avengers-endgame">Avengers: Endgame</a></li>
<li id="menu-item-105503" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105503"><a href="http://52.206.29.228/tag/ant-man-and-the-wasp/">Ant Man &#038; The Wasp</a></li>
<li id="menu-item-59608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59608"><a href="http://52.206.29.228/tag/avengers-infinity-war/">Avengers: Infinity War</a></li>
<li id="menu-item-79772" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79772"><a href="http://52.206.29.228/tag/captain-marvel">Captain Marvel</a></li>
<li id="menu-item-121763" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121763"><a href="http://52.206.29.228/tag/dark-phoenix">X-Men: Dark Phoenix</a></li>
<li id="menu-item-121761" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121761"><a href="http://52.206.29.228/tag/spiderman-far-from-home">Spider-Man: Far Frome Home</a></li>
</ul>
</li>
<li id="menu-item-123308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-123308"><a href="http://52.206.29.228/tag/star-wars/">Star Wars<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-105500" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105500"><a href="http://52.206.29.228/tag/star-wars-episode-IX">Star Wars: Episode IX</a></li>
</ul>
</li>
<li id="menu-item-121767" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-121767"><a href="http://52.206.29.228/tag/universal-pictures/">Universal Pictures<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-121768" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121768"><a href="http://52.206.29.228/tag/the-grinch">Dr. Seuss&#8217; The Grinch</a></li>
<li id="menu-item-121770" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121770"><a href="http://52.206.29.228/tag/how-to-train-your-dragon/">How to Train Your Dragon: The Hidden World</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-10505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10505"><a href="http://fanfest.com/category/tv-shows/">TV<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-10623" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10623"><a href="http://52.206.29.228/tag/agents-of-shield/">Agents of S.H.I.E.L.D</a></li>
<li id="menu-item-10588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10588"><a href="http://52.206.29.228/tag/arrow/">Arrow</a></li>
<li id="menu-item-121777" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121777"><a href="http://52.206.29.228/tag/black-lightning/">Black Lightning</a></li>
<li id="menu-item-105425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105425"><a href="http://52.206.29.228/tag/bosch/">Bosch</a></li>
<li id="menu-item-121778" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121778"><a href="http://52.206.29.228/tag/ducktales/">Ducktales</a></li>
<li id="menu-item-121779" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121779"><a href="http://52.206.29.228/tag/legend-of-tomorrow/">DC&#8217;s Legends of Tomorrow</a></li>
<li id="menu-item-121780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121780"><a href="http://52.206.29.228/tag/fear-the-walking-dead/">Fear The Walking Dead</a></li>
<li id="menu-item-10587" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10587"><a href="http://52.206.29.228/tag/game-of-thrones/">Game of Thrones</a></li>
<li id="menu-item-10589" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10589"><a href="http://52.206.29.228/tag/gotham/">Gotham</a></li>
<li id="menu-item-121772" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121772"><a href="http://52.206.29.228/tag/hallmark/">Hallmark</a></li>
<li id="menu-item-121775" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121775"><a href="http://52.206.29.228/tag/the-big-bang-theory/">The Big Bang Theory</a></li>
<li id="menu-item-10624" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10624"><a href="http://52.206.29.228/tag/the-flash/">The Flash</a></li>
<li id="menu-item-121774" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121774"><a href="http://52.206.29.228/tag/the-good-doctor/">The Good Doctor</a></li>
<li id="menu-item-10586" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10586"><a href="http://52.206.29.228/tag/the-walking-dead/">The Walking Dead</a></li>
<li id="menu-item-121782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121782"><a href="http://52.206.29.228/tag/stranger-things/">Stranger Things</a></li>
<li id="menu-item-10626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10626"><a href="http://52.206.29.228/tag/supernatural/">Supernatural</a></li>
<li id="menu-item-10625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10625"><a href="http://52.206.29.228/tag/supergirl/">Supergirl</a></li>
<li id="menu-item-125871" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-125871"><a href="http://52.206.29.228/tag/titans/">Titans</a></li>
<li id="menu-item-124088" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-124088"><a href="http://52.206.29.228/tag/vikings/">Vikings</a></li>
<li id="menu-item-121776" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121776"><a href="http://52.206.29.228/tag/young-sheldon/">Young Sheldon</a></li>
</ul>
</li>
<li id="menu-item-126094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-126094"><a href="http://52.206.29.228/tag/video-games/">Gaming</a></li>
<li id="menu-item-132380" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-132380"><a href="http://52.206.29.228/tag/comics/">Comic Books</a></li>
<li id="menu-item-30947" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30947"><a href="http://52.206.29.228/tag/interviews/">Interviews</a></li>
<li id="menu-item-10517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10517"><a href="http://fanfest.com/videos/">Videos<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-105936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105936"><a href="https://www.youtube.com/user/TheWalkerStalkers1">All Videos</a></li>
<li id="menu-item-10519" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10519"><a href="http://fanfest.com/originals/">Fan Fest Originals</a></li>
<li id="menu-item-68275" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68275"><a href="http://52.206.29.228/tag/the-nightly-nerd/">The Nightly Nerd</a></li>
<li id="menu-item-53744" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53744"><a href="http://52.206.29.228/tag/geeksterink/">Fan Fest Original Series: GEEKSTERINK</a></li>
<li id="menu-item-39295" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39295"><a href="http://52.206.29.228/tag/control/">Fan Fest Original Series: CONTROL</a></li>
<li id="menu-item-11305" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11305"><a href="http://fanfest.com/downndirty/">Down &#8216;N Dirty with Kyla Kenedy</a></li>
</ul>
</li>
<li id="menu-item-10508" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10508"><a href="http://fanfest.com/about/">About<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-10507" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10507"><a href="http://fanfest.com/contact/">Contact</a></li>
<li id="menu-item-147062" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-147062"><a href="http://fanfest.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-147061" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-147061"><a href="http://fanfest.com/cookies-policy/">Cookies Policy</a></li>
</ul>
</li>
<li id="menu-item-65259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65259"><a href="http://52.206.29.228/tag/fun">For Fun</a></li>
<li id="menu-item-145041" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145041"><a href="http://fanfest.com/christmas-holiday-gift-guides/">Holiday Gift Guides</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://fanfest.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-1 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="td_data_time">
<div>
Saturday, May 9, 2020
</div>
</div>
</div>
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/FanFestNews" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/fanfestnews/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/FanFestNews" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div> </div>

</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="http://fanfest.com/">
<img src="http://52.206.29.228/wp-content/uploads/2018/10/Fan-Fest-NEWS-logo_3.png" alt="" />
<span class="td-visual-hidden">Fan Fest | For Fans, By Fans</span>
</a>
</div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient ">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="http://fanfest.com/">
<img src="http://52.206.29.228/wp-content/uploads/2018/10/Fan-Fest-NEWS-logo_3.png" alt="" />
</a>
</div>
<div class="menu-footer-container"><ul id="menu-footer-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-123226"><a href="http://fanfest.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-10504"><a href="http://fanfest.com/category/movies/">Movies</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-123303"><a href="http://52.206.29.228/tag/dc/">DC</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-123306"><a href="http://52.206.29.228/tag/aquaman/">Aquaman</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-123305"><a href="http://52.206.29.228/tag/shazam/">SHAZAM!</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-123307"><a href="http://52.206.29.228/tag/wonder-woman/">Wonder Woman 1984</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-105505"><a href="http://52.206.29.228/tag/disney/">Disney</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121765"><a href="http://52.206.29.228/tag/dumbo">Dumbo</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121764"><a href="http://52.206.29.228/tag/mary-poppins">Mary Poppins Returns</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-105506"><a href="http://52.206.29.228/tag/ralph-breaks-the-internet/">Ralph Breaks The Internet</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-123857"><a href="http://52.206.29.228/tag/the-lion-king/">The Lion King</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-123302"><a href="http://52.206.29.228/tag/harry-potter/">Wizarding World of Harry Potter</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-105504"><a href="http://52.206.29.228/tag/fantastic-beasts-the-crimes-of-grindelwald/">Fantastic Beasts: The Crimes of Grindelwald</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-105501"><a href="http://52.206.29.228/tag/marvel/">Marvel</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121760"><a href="http://52.206.29.228/tag/avengers-endgame">Avengers: Endgame</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-105503"><a href="http://52.206.29.228/tag/ant-man-and-the-wasp/">Ant Man &#038; The Wasp</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-59608"><a href="http://52.206.29.228/tag/avengers-infinity-war/">Avengers: Infinity War</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-79772"><a href="http://52.206.29.228/tag/captain-marvel">Captain Marvel</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121763"><a href="http://52.206.29.228/tag/dark-phoenix">X-Men: Dark Phoenix</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121761"><a href="http://52.206.29.228/tag/spiderman-far-from-home">Spider-Man: Far Frome Home</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-123308"><a href="http://52.206.29.228/tag/star-wars/">Star Wars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-105500"><a href="http://52.206.29.228/tag/star-wars-episode-IX">Star Wars: Episode IX</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-121767"><a href="http://52.206.29.228/tag/universal-pictures/">Universal Pictures</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121768"><a href="http://52.206.29.228/tag/the-grinch">Dr. Seuss&#8217; The Grinch</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121770"><a href="http://52.206.29.228/tag/how-to-train-your-dragon/">How to Train Your Dragon: The Hidden World</a></li>
</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-10505"><a href="http://fanfest.com/category/tv-shows/">TV</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10623"><a href="http://52.206.29.228/tag/agents-of-shield/">Agents of S.H.I.E.L.D</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10588"><a href="http://52.206.29.228/tag/arrow/">Arrow</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121777"><a href="http://52.206.29.228/tag/black-lightning/">Black Lightning</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-105425"><a href="http://52.206.29.228/tag/bosch/">Bosch</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121778"><a href="http://52.206.29.228/tag/ducktales/">Ducktales</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121779"><a href="http://52.206.29.228/tag/legend-of-tomorrow/">DC&#8217;s Legends of Tomorrow</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121780"><a href="http://52.206.29.228/tag/fear-the-walking-dead/">Fear The Walking Dead</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10587"><a href="http://52.206.29.228/tag/game-of-thrones/">Game of Thrones</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10589"><a href="http://52.206.29.228/tag/gotham/">Gotham</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121772"><a href="http://52.206.29.228/tag/hallmark/">Hallmark</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121775"><a href="http://52.206.29.228/tag/the-big-bang-theory/">The Big Bang Theory</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10624"><a href="http://52.206.29.228/tag/the-flash/">The Flash</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121774"><a href="http://52.206.29.228/tag/the-good-doctor/">The Good Doctor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10586"><a href="http://52.206.29.228/tag/the-walking-dead/">The Walking Dead</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121782"><a href="http://52.206.29.228/tag/stranger-things/">Stranger Things</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10626"><a href="http://52.206.29.228/tag/supernatural/">Supernatural</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10625"><a href="http://52.206.29.228/tag/supergirl/">Supergirl</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-125871"><a href="http://52.206.29.228/tag/titans/">Titans</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-124088"><a href="http://52.206.29.228/tag/vikings/">Vikings</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-121776"><a href="http://52.206.29.228/tag/young-sheldon/">Young Sheldon</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-126094"><a href="http://52.206.29.228/tag/video-games/">Gaming</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-132380"><a href="http://52.206.29.228/tag/comics/">Comic Books</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-30947"><a href="http://52.206.29.228/tag/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-10517"><a href="http://fanfest.com/videos/">Videos</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-105936"><a href="https://www.youtube.com/user/TheWalkerStalkers1">All Videos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-10519"><a href="http://fanfest.com/originals/">Fan Fest Originals</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-68275"><a href="http://52.206.29.228/tag/the-nightly-nerd/">The Nightly Nerd</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-53744"><a href="http://52.206.29.228/tag/geeksterink/">Fan Fest Original Series: GEEKSTERINK</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-39295"><a href="http://52.206.29.228/tag/control/">Fan Fest Original Series: CONTROL</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-11305"><a href="http://fanfest.com/downndirty/">Down &#8216;N Dirty with Kyla Kenedy</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-10508"><a href="http://fanfest.com/about/">About</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-10507"><a href="http://fanfest.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-147062"><a href="http://fanfest.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-147061"><a href="http://fanfest.com/cookies-policy/">Cookies Policy</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-65259"><a href="http://52.206.29.228/tag/fun">For Fun</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-145041"><a href="http://fanfest.com/christmas-holiday-gift-guides/">Holiday Gift Guides</a></li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://fanfest.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-150467" class="post-150467 post type-post status-publish format-standard has-post-thumbnail category-reviews category-video-games tag-gaming tag-infuse-studio tag-journey tag-merge-games tag-puzzle tag-review tag-spirit-of-the-north tag-video-games tag-walking-sim" itemscope itemtype="http://schema.org/Article" 46>
<div class="td-post-header">

<header class="td-post-title">
<h1 class="entry-title">&#8216;Spirit of the North&#8217; Review (Nintendo Switch)</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://fanfest.com/author/richard/">Richard Allen</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-07T09:01:26+00:00">May 7, 2020</time></span> <div class="td-post-comments"><a href="http://fanfest.com/spirit-of-the-north-review-nintendo-switch/#respond"><i class="td-icon-comments"></i>0</a></div>  </div>
</header>
</div>
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Ffanfest.com%2Fspirit-of-the-north-review-nintendo-switch%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=%E2%80%98Spirit+of+the+North%E2%80%99+Review+%28Nintendo+Switch%29&url=http%3A%2F%2Ffanfest.com%2Fspirit-of-the-north-review-nintendo-switch%2F&via=Fan+Fest+%7C+For+Fans%2C+By+Fans">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://fanfest.com/spirit-of-the-north-review-nintendo-switch/&amp;media=http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04.jpg&description=Spirit of the North, created by Infuse Studio and published by Merge Games, is a thought-provoking, albeit short, adventure.">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=%E2%80%98Spirit+of+the+North%E2%80%99+Review+%28Nintendo+Switch%29 %0A%0A http://fanfest.com/spirit-of-the-north-review-nintendo-switch/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<div class="td-post-featured-image"><figure><a href="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04.jpg" data-caption="Photo Credit: Infuse Studio / Merge Games"><img width="696" height="392" class="entry-thumb td-modal-image" src="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04-696x392.jpg" srcset="http://fanfest.com/wp-content/uploads/2020/05/xSOTN_Store_Image_04-696x392.jpg.pagespeed.ic.1OPXbdavdh.jpg 696w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04-300x169.jpg 300w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04-1024x576.jpg 1024w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04-768x432.jpg 768w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04-1536x864.jpg 1536w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04-1068x601.jpg 1068w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04-747x420.jpg 747w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04.jpg 1920w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="SOTN_Store_Image_04" /></a><figcaption class="wp-caption-text">Photo Credit: Infuse Studio / Merge Games</figcaption></figure></div>
<p><em><a href="https://www.playspiritofthenorth.com/">Spirit of the North</a>, </em>created by <a href="https://infusedstudio.com/">Infuse Studio</a> and published by <a href="https://www.mergegames.com/">Merge Games</a>, is a thought-provoking, albeit short, adventure told solely through subtle landscapes and mystical puzzles; at its heart <em>Spirit of the North </em>is a lonely trek across a barren land in search of meaning.</p>
<figure id="attachment_150476" aria-describedby="caption-attachment-150476" style="width: 696px" class="wp-caption aligncenter"><a href="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_09.jpg"><img class="size-large wp-image-150476" src="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_09-1024x576.jpg" alt="" width="696" height="392" srcset="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_09-1024x576.jpg 1024w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_09-300x169.jpg 300w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_09-768x432.jpg 768w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_09-1536x864.jpg 1536w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_09-696x392.jpg 696w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_09-1068x601.jpg 1068w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_09-747x420.jpg 747w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_09.jpg 1920w" sizes="(max-width: 696px) 100vw, 696px" /></a><figcaption id="caption-attachment-150476" class="wp-caption-text">Photo Credit: Infuse Studio / Merge Games</figcaption></figure>
<p>Players take the reins of an ordinary fox chosen by the guardian of the northern lights, a female spirit fox, to aid in a solemn quest.  With no dialogue or text, the story is instead told through the scenery; snowy abysses, abandoned castles, deep caverns, and lush hillsides all tell the story of a once populated world, long since abandoned.</p>
<p>Throughout your travels you will not encounter any other living beings, although you will encounter the numerous remains of Shamans long ago deceased and aid in bringing closure to their lives. These 28 hidden Shamans serve as the only deviation from your otherwise narrow-minded trek toward the source of the Northern Lights.</p>
<figure id="attachment_150477" aria-describedby="caption-attachment-150477" style="width: 696px" class="wp-caption aligncenter"><a href="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_11.jpg"><img class="size-large wp-image-150477" src="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_11-1024x576.jpg" alt="" width="696" height="392" srcset="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_11-1024x576.jpg 1024w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_11-300x169.jpg 300w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_11-768x432.jpg 768w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_11-1536x864.jpg 1536w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_11-696x392.jpg 696w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_11-1068x601.jpg 1068w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_11-747x420.jpg 747w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_11.jpg 1920w" sizes="(max-width: 696px) 100vw, 696px" /></a><figcaption id="caption-attachment-150477" class="wp-caption-text">Photo Credit: Infuse Studio / Merge Games</figcaption></figure>
<figure id="attachment_150475" aria-describedby="caption-attachment-150475" style="width: 696px" class="wp-caption aligncenter"><a href="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_08.jpg"><img class="size-large wp-image-150475" src="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_08-1024x576.jpg" alt="" width="696" height="392" srcset="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_08-1024x576.jpg 1024w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_08-300x169.jpg 300w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_08-768x432.jpg 768w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_08-1536x864.jpg 1536w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_08-696x392.jpg 696w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_08-1068x601.jpg 1068w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_08-747x420.jpg 747w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_08.jpg 1920w" sizes="(max-width: 696px) 100vw, 696px" /></a><figcaption id="caption-attachment-150475" class="wp-caption-text">Photo Credit: Infuse Studio / Merge Games</figcaption></figure>
<p>In place of dialogue is a subdued and haunting score, a perfect backdrop to the gorgeous scenery strewn throughout the fox’s adventure and a constant reminder of the beauty inherent even when hope seems lost and the world is crumbling.</p>
<p>At its core <em>Spirit of the North</em> is a walking simulator akin to <em>Journey </em>or <em>Everybody’s Gone to the Rapture</em>. There are no enemies. There is no way for the player to die. There is only a weathered landscape full of puzzles. The puzzles, while never hard, do help to break up the walking and keep things fresh for the game’s relatively short run time.</p>
<figure id="attachment_150474" aria-describedby="caption-attachment-150474" style="width: 696px" class="wp-caption aligncenter"><a href="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_07.jpg"><img class="size-large wp-image-150474" src="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_07-1024x576.jpg" alt="" width="696" height="392" srcset="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_07-1024x576.jpg 1024w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_07-300x169.jpg 300w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_07-768x432.jpg 768w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_07-1536x864.jpg 1536w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_07-696x392.jpg 696w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_07-1068x601.jpg 1068w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_07-747x420.jpg 747w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_07.jpg 1920w" sizes="(max-width: 696px) 100vw, 696px" /></a><figcaption id="caption-attachment-150474" class="wp-caption-text">Photo Credit: Infuse Studio / Merge Games</figcaption></figure>
<figure id="attachment_150473" aria-describedby="caption-attachment-150473" style="width: 696px" class="wp-caption aligncenter"><a href="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_06.jpg"><img class="size-large wp-image-150473" src="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_06-1024x576.jpg" alt="" width="696" height="392" srcset="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_06-1024x576.jpg 1024w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_06-300x169.jpg 300w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_06-768x432.jpg 768w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_06-1536x864.jpg 1536w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_06-696x392.jpg 696w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_06-1068x601.jpg 1068w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_06-747x420.jpg 747w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_06.jpg 1920w" sizes="(max-width: 696px) 100vw, 696px" /></a><figcaption id="caption-attachment-150473" class="wp-caption-text">Photo Credit: Infuse Studio / Merge Games</figcaption></figure>
<p>There is no map, no way points, no arrows, and no signs to help guide you &#8211; only subtle cues lead the way. The environment is the only guide you need, although in particularly convoluted areas you are helped by a guiding spirit who subtly nudges you in the right direction while never quite spelling out the solution of how to get there. While at first your instincts may be thrown off by the lack of direction, eventually you learn to take the game in stride and how to react to the World surrounding you in a natural way. It is a testament to the game’s design that you never feel lost or overwhelmed despite the large landscapes.</p>
<p><em>Spirit of the North </em>is divided into 8 chapters, each of which introduces a new area and normally a new gameplay mechanic. The fox begins the game with no supernatural powers and no abilities to speak of – only able to wag his tail and to bark. As you progress you gain abilities akin to the spirit fox, allowing you to separate your soul from your body to reach new areas, unleash a howl to eradicate dangers, dash long distances, and more, each skill becoming absolutely necessary to progress through the increasingly complicated chapters.</p>
<figure id="attachment_150472" aria-describedby="caption-attachment-150472" style="width: 696px" class="wp-caption aligncenter"><a href="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_05.jpg"><img class="size-large wp-image-150472" src="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_05-1024x576.jpg" alt="" width="696" height="392" srcset="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_05-1024x576.jpg 1024w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_05-300x169.jpg 300w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_05-768x432.jpg 768w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_05-1536x864.jpg 1536w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_05-696x392.jpg 696w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_05-1068x601.jpg 1068w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_05-747x420.jpg 747w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_05.jpg 1920w" sizes="(max-width: 696px) 100vw, 696px" /></a><figcaption id="caption-attachment-150472" class="wp-caption-text">Photo Credit: Infuse Studio / Merge Games</figcaption></figure>
<figure id="attachment_150470" aria-describedby="caption-attachment-150470" style="width: 696px" class="wp-caption aligncenter"><a href="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_03.jpg"><img class="size-large wp-image-150470" src="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_03-1024x576.jpg" alt="" width="696" height="392" srcset="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_03-1024x576.jpg 1024w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_03-300x169.jpg 300w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_03-768x432.jpg 768w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_03-1536x864.jpg 1536w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_03-696x392.jpg 696w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_03-1068x601.jpg 1068w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_03-747x420.jpg 747w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_03.jpg 1920w" sizes="(max-width: 696px) 100vw, 696px" /></a><figcaption id="caption-attachment-150470" class="wp-caption-text">Photo Credit: Infuse Studio / Merge Games</figcaption></figure>
<p>Aside from puzzles, there is a good bit of platforming – which unfortunately is one of the game’s weaker aspects. Some areas are rather hard to clear due to timing issues and distance issues, further hurt by occasionally clunky controls. For most of the game the controls do not hamper enjoyment, but issues quickly become apparent in some late-game platforming obstacles. While the issues were never dire enough to ruin my enjoyment, I did spend more time than I’d like in a few areas trying to get the timing of a jump correct.</p>
<p>At only four hours long, <em>Spirit of the North</em> never overstays its welcome. The varied landscape and constantly changing puzzles ensure gameplay remains fresh throughout, while the thought-provoking scenery and the anticipation of what’s to come will keep players enthralled. Those looking for a subdued yet beautifully orchestrated experience should look no further than <em>Spirit of the North</em>.</p>
<figure id="attachment_150469" aria-describedby="caption-attachment-150469" style="width: 696px" class="wp-caption aligncenter"><a href="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_02.jpg"><img class="size-large wp-image-150469" src="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_02-1024x576.jpg" alt="" width="696" height="392" srcset="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_02-1024x576.jpg 1024w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_02-300x169.jpg 300w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_02-768x432.jpg 768w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_02-1536x864.jpg 1536w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_02-696x392.jpg 696w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_02-1068x601.jpg 1068w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_02-747x420.jpg 747w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_02.jpg 1920w" sizes="(max-width: 696px) 100vw, 696px" /></a><figcaption id="caption-attachment-150469" class="wp-caption-text">Photo Credit: Infuse Studio / Merge Games</figcaption></figure>
<figure id="attachment_150468" aria-describedby="caption-attachment-150468" style="width: 696px" class="wp-caption aligncenter"><a href="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_01.jpg"><img class="size-large wp-image-150468" src="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_01-1024x576.jpg" alt="" width="696" height="392" srcset="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_01-1024x576.jpg 1024w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_01-300x169.jpg 300w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_01-768x432.jpg 768w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_01-1536x864.jpg 1536w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_01-696x392.jpg 696w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_01-1068x601.jpg 1068w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_01-747x420.jpg 747w, http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_01.jpg 1920w" sizes="(max-width: 696px) 100vw, 696px" /></a><figcaption id="caption-attachment-150468" class="wp-caption-text">Photo Credit: Infuse Studio / Merge Games</figcaption></figure>
<p><strong><em>Spirit of the North</em> is out on May 7<sup>th</sup> on the Nintendo Switch and PC for $24.99. <em>Spirit of the North</em> is also available on PS4. Thank you to Merge Games and Infuse Studio for provided Fan Fest News with a review code of <em>Spirit of the North</em>.</strong></p>
</div>
<footer>
 
<div class="td-post-source-tags">
  </div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=http://fanfest.com/spirit-of-the-north-review-nintendo-switch/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Ffanfest.com%2Fspirit-of-the-north-review-nintendo-switch%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=%E2%80%98Spirit+of+the+North%E2%80%99+Review+%28Nintendo+Switch%29&url=http%3A%2F%2Ffanfest.com%2Fspirit-of-the-north-review-nintendo-switch%2F&via=Fan+Fest+%7C+For+Fans%2C+By+Fans">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://fanfest.com/spirit-of-the-north-review-nintendo-switch/&amp;media=http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04.jpg&description=Spirit of the North, created by Infuse Studio and published by Merge Games, is a thought-provoking, albeit short, adventure.">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=%E2%80%98Spirit+of+the+North%E2%80%99+Review+%28Nintendo+Switch%29 %0A%0A http://fanfest.com/spirit-of-the-north-review-nintendo-switch/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://fanfest.com/streets-of-rage-4-physical-edition-announced/">&#8216;Streets of Rage 4&#8217; Physical Edition and Signature Games Edition Announced</a></div></div><div class="td-next-prev-separator"></div></div> <div class="author-box-wrap"><a href="http://fanfest.com/author/richard/"><img alt='' src="https://0.gravatar.com/avatar/3e0c6bed98e8c3ec70735501bdbde2ea?s=96&#038;d=mm&#038;r=g" srcset='http://0.gravatar.com/avatar/3e0c6bed98e8c3ec70735501bdbde2ea?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://fanfest.com/author/richard/">Richard Allen</a></span></div><div class="td-author-description">Richard Allen is a freelance writer and contributing editor for various publications. When he's not writing about video games on FanFest.com you can find him on Broadway World or in Graffiti Magazine. He can be contacted via email at <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="186a717b70796a7c582d2a362a282e362a21362a2a20">[email&#160;protected]</a> or <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="dcaeb5bfb4bdaeb8bdb0b0b9b2abaeb5a8b9af9cbbb1bdb5b0f2bfb3b1f2">[email&#160;protected]</a> You can visit his website at facebook.com/richardallenwrites</div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Richard Allen"></span><meta itemprop="datePublished" content="2020-05-07T09:01:26+00:00"><meta itemprop="dateModified" content="2020-05-07T09:01:26-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://fanfest.com/spirit-of-the-north-review-nintendo-switch/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://52.206.29.228/wp-content/uploads/2018/10/Fan-Fest-NEWS-logo_3.png"></span><meta itemprop="name" content="Fan Fest | For Fans, By Fans"></span><meta itemprop="headline " content="&#039;Spirit of the North&#039; Review (Nintendo Switch)"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://fanfest.com/wp-content/uploads/2020/05/SOTN_Store_Image_04.jpg"><meta itemprop="width" content="1920"><meta itemprop="height" content="1080"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts td_uid_2_5eb718c8e4ddb_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_2_5eb718c8e4ddb"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_td_uid_2_5eb718c8e4ddb=new tdBlock();block_td_uid_2_5eb718c8e4ddb.id="td_uid_2_5eb718c8e4ddb";block_td_uid_2_5eb718c8e4ddb.atts='{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_2_5eb718c8e4ddb_rand","td_column_number":3,"live_filter_cur_post_id":150467,"live_filter_cur_post_author":"129","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_2_5eb718c8e4ddb_rand","tdc_css_class_style":"td_uid_2_5eb718c8e4ddb_rand_style"}';block_td_uid_2_5eb718c8e4ddb.td_column_number="3";block_td_uid_2_5eb718c8e4ddb.block_type="td_block_related_posts";block_td_uid_2_5eb718c8e4ddb.post_count="6";block_td_uid_2_5eb718c8e4ddb.found_posts="1402";block_td_uid_2_5eb718c8e4ddb.header_color="";block_td_uid_2_5eb718c8e4ddb.ajax_pagination_infinite_stop="";block_td_uid_2_5eb718c8e4ddb.max_num_pages="234";tdBlocksArray.push(block_td_uid_2_5eb718c8e4ddb);</script><h4 class="td-related-title td-block-title"><a id="td_uid_3_5eb718c8e962e" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_2_5eb718c8e4ddb" href="#">RELATED ARTICLES</a><a id="td_uid_4_5eb718c8e9633" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_2_5eb718c8e4ddb" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_2_5eb718c8e4ddb class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://fanfest.com/streets-of-rage-4-physical-edition-announced/" rel="bookmark" class="td-image-wrap" title="&#8216;Streets of Rage 4&#8217; Physical Edition and Signature Games Edition Announced"><img width="218" height="150" class="entry-thumb" src="http://fanfest.com/wp-content/uploads/2020/05/xstreets1-218x150.jpeg.pagespeed.ic.n67xtr1za5.jpg" srcset="http://fanfest.com/wp-content/uploads/2020/05/xstreets1-218x150.jpeg.pagespeed.ic.n67xtr1za5.jpg 218w, http://fanfest.com/wp-content/uploads/2020/05/xstreets1-100x70.jpeg.pagespeed.ic.nfw1PLG7JL.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="&#8216;Streets of Rage 4&#8217; Physical Edition and Signature Games Edition Announced" /></a></div> <a href="http://fanfest.com/category/video-games/" class="td-post-category">Video Games</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://fanfest.com/streets-of-rage-4-physical-edition-announced/" rel="bookmark" title="&#8216;Streets of Rage 4&#8217; Physical Edition and Signature Games Edition Announced">&#8216;Streets of Rage 4&#8217; Physical Edition and Signature Games Edition Announced</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://fanfest.com/it-came-from-space-and-ate-our-brains-review-xbox-one/" rel="bookmark" class="td-image-wrap" title="&#8216;It Came From Space and Ate Our Brains&#8217; Review (Xbox One)"><img width="218" height="150" class="entry-thumb" src="http://fanfest.com/wp-content/uploads/2020/05/xspace2-218x150.jpg.pagespeed.ic.VF9Q0_O_kC.jpg" srcset="http://fanfest.com/wp-content/uploads/2020/05/xspace2-218x150.jpg.pagespeed.ic.VF9Q0_O_kC.jpg 218w, http://fanfest.com/wp-content/uploads/2020/05/xspace2-100x70.jpg.pagespeed.ic.M-CD17RRfZ.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="&#8216;It Came From Space and Ate Our Brains&#8217; Review (Xbox One)" /></a></div> <a href="http://fanfest.com/category/reviews/" class="td-post-category">Reviews</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://fanfest.com/it-came-from-space-and-ate-our-brains-review-xbox-one/" rel="bookmark" title="&#8216;It Came From Space and Ate Our Brains&#8217; Review (Xbox One)">&#8216;It Came From Space and Ate Our Brains&#8217; Review (Xbox One)</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://fanfest.com/resident-evil-resistance-review-xbox-one/" rel="bookmark" class="td-image-wrap" title="&#8216;Resident Evil: Resistance&#8217; Review (Xbox One)"><img width="218" height="150" class="entry-thumb" src="http://fanfest.com/wp-content/uploads/2020/04/xresistance-9-218x150.jpg.pagespeed.ic.gPYj96s8kU.jpg" srcset="http://fanfest.com/wp-content/uploads/2020/04/xresistance-9-218x150.jpg.pagespeed.ic.gPYj96s8kU.jpg 218w, http://fanfest.com/wp-content/uploads/2020/04/xresistance-9-100x70.jpg.pagespeed.ic.0veylUYG8z.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="&#8216;Resident Evil: Resistance&#8217; Review (Xbox One)" /></a></div> <a href="http://fanfest.com/category/reviews/" class="td-post-category">Reviews</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://fanfest.com/resident-evil-resistance-review-xbox-one/" rel="bookmark" title="&#8216;Resident Evil: Resistance&#8217; Review (Xbox One)">&#8216;Resident Evil: Resistance&#8217; Review (Xbox One)</a></h3> </div>
</div>
</div> </div>
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://fanfest.com/season-2-is-the-most-brilliant-season-of-call-of-duty-yet/" rel="bookmark" class="td-image-wrap" title="Season 2 Is The Most Brilliant Season Of &#8216;Call Of Duty: Modern Warfare&#8217; Yet"><img width="218" height="150" class="entry-thumb" src="http://fanfest.com/wp-content/uploads/2020/04/xAGB_S2_Launch_Ghost_2-218x150.jpg.pagespeed.ic.FxMItL21rv.jpg" srcset="http://fanfest.com/wp-content/uploads/2020/04/xAGB_S2_Launch_Ghost_2-218x150.jpg.pagespeed.ic.FxMItL21rv.jpg 218w, http://fanfest.com/wp-content/uploads/2020/04/xAGB_S2_Launch_Ghost_2-100x70.jpg.pagespeed.ic.zUw8pEiGRu.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="season 2 recap call of duty" title="Season 2 Is The Most Brilliant Season Of &#8216;Call Of Duty: Modern Warfare&#8217; Yet" /></a></div> <a href="http://fanfest.com/category/originals/" class="td-post-category">Originals</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://fanfest.com/season-2-is-the-most-brilliant-season-of-call-of-duty-yet/" rel="bookmark" title="Season 2 Is The Most Brilliant Season Of &#8216;Call Of Duty: Modern Warfare&#8217; Yet">Season 2 Is The Most Brilliant Season Of &#8216;Call Of Duty: Modern Warfare&#8217; Yet</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://fanfest.com/the-last-of-us-part-ii-is-delayed-again-and-indefinitely/" rel="bookmark" class="td-image-wrap" title="&#8216;The Last Of Us Part II&#8217; Is Delayed&#8230; Again&#8230; And Indefinitely"><img width="218" height="150" class="entry-thumb" src="http://fanfest.com/wp-content/uploads/2020/04/xKey-Art-Images-Dark-for-Feb-11-Blog_200304_205559-218x150.jpg.pagespeed.ic.qA4pctU7oV.jpg" srcset="http://fanfest.com/wp-content/uploads/2020/04/xKey-Art-Images-Dark-for-Feb-11-Blog_200304_205559-218x150.jpg.pagespeed.ic.qA4pctU7oV.jpg 218w, http://fanfest.com/wp-content/uploads/2020/04/xKey-Art-Images-Dark-for-Feb-11-Blog_200304_205559-100x70.jpg.pagespeed.ic.ZQyo93uM-B.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="&#8216;The Last Of Us Part II&#8217; Is Delayed&#8230; Again&#8230; And Indefinitely" /></a></div> <a href="http://fanfest.com/category/news/" class="td-post-category">News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://fanfest.com/the-last-of-us-part-ii-is-delayed-again-and-indefinitely/" rel="bookmark" title="&#8216;The Last Of Us Part II&#8217; Is Delayed&#8230; Again&#8230; And Indefinitely">&#8216;The Last Of Us Part II&#8217; Is Delayed&#8230; Again&#8230; And Indefinitely</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://fanfest.com/resident-evil-3-review-xbox-one/" rel="bookmark" class="td-image-wrap" title="&#8216;Resident Evil 3&#8217; Review (Xbox One)"><img width="218" height="150" class="entry-thumb" src="http://fanfest.com/wp-content/uploads/2020/04/xre3-7-218x150.jpg.pagespeed.ic.n7e2ce8WQa.jpg" srcset="http://fanfest.com/wp-content/uploads/2020/04/xre3-7-218x150.jpg.pagespeed.ic.n7e2ce8WQa.jpg 218w, http://fanfest.com/wp-content/uploads/2020/04/xre3-7-100x70.jpg.pagespeed.ic.h0OGm978iq.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="&#8216;Resident Evil 3&#8217; Review (Xbox One)" /></a></div> <a href="http://fanfest.com/category/reviews/" class="td-post-category">Reviews</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://fanfest.com/resident-evil-3-review-xbox-one/" rel="bookmark" title="&#8216;Resident Evil 3&#8217; Review (Xbox One)">&#8216;Resident Evil 3&#8217; Review (Xbox One)</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5eb718c8e4ddb" data-td_block_id="td_uid_2_5eb718c8e4ddb"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_2_5eb718c8e4ddb" data-td_block_id="td_uid_2_5eb718c8e4ddb"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/spirit-of-the-north-review-nintendo-switch/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://fanfest.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
<div class="comment-form-input-wrap td-form-comment">
<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
<div class="td-warning-comment">Please enter your comment!</div>
</div>
<div class="comment-form-input-wrap td-form-author">
<input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-author">Please enter your name here</div>
</div>
<div class="comment-form-input-wrap td-form-email">
<input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-email-error">You have entered an incorrect email address!</div>
<div class="td-warning-email">Please enter your email address here</div>
</div>
<div class="comment-form-input-wrap td-form-url">
<input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
</div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='150467' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7fca7d5bfa" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="232" /></p></form> </div>
</div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="sidebar-1">
</div></div></aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="sidebar-2">
</div></div></aside><div class="td_block_wrap td_block_1 td_block_widget td_uid_5_5eb718c8eb9d9_rand td-pb-border-top td_block_template_1 td-column-1" data-td-block-uid="td_uid_5_5eb718c8eb9d9"><script>var block_td_uid_5_5eb718c8eb9d9=new tdBlock();block_td_uid_5_5eb718c8eb9d9.id="td_uid_5_5eb718c8eb9d9";block_td_uid_5_5eb718c8eb9d9.atts='{"custom_title":"Featured Articles","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","accent_text_color":"#","m4_tl":"","m4_el":"","m6_tl":"","limit":"4","offset":"","el_class":"","post_ids":"","category_id":"6031","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_5_5eb718c8eb9d9_rand","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m4f_title_font_header":"","m4f_title_font_title":"Article title","m4f_title_font_settings":"","m4f_title_font_family":"","m4f_title_font_size":"","m4f_title_font_line_height":"","m4f_title_font_style":"","m4f_title_font_weight":"","m4f_title_font_transform":"","m4f_title_font_spacing":"","m4f_title_":"","m4f_cat_font_title":"Article category tag","m4f_cat_font_settings":"","m4f_cat_font_family":"","m4f_cat_font_size":"","m4f_cat_font_line_height":"","m4f_cat_font_style":"","m4f_cat_font_weight":"","m4f_cat_font_transform":"","m4f_cat_font_spacing":"","m4f_cat_":"","m4f_meta_font_title":"Article meta info","m4f_meta_font_settings":"","m4f_meta_font_family":"","m4f_meta_font_size":"","m4f_meta_font_line_height":"","m4f_meta_font_style":"","m4f_meta_font_weight":"","m4f_meta_font_transform":"","m4f_meta_font_spacing":"","m4f_meta_":"","m4f_ex_font_title":"Article excerpt","m4f_ex_font_settings":"","m4f_ex_font_family":"","m4f_ex_font_size":"","m4f_ex_font_line_height":"","m4f_ex_font_style":"","m4f_ex_font_weight":"","m4f_ex_font_transform":"","m4f_ex_font_spacing":"","m4f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_5_5eb718c8eb9d9_rand","tdc_css_class_style":"td_uid_5_5eb718c8eb9d9_rand_style"}';block_td_uid_5_5eb718c8eb9d9.td_column_number="1";block_td_uid_5_5eb718c8eb9d9.block_type="td_block_1";block_td_uid_5_5eb718c8eb9d9.post_count="4";block_td_uid_5_5eb718c8eb9d9.found_posts="6675";block_td_uid_5_5eb718c8eb9d9.header_color="#";block_td_uid_5_5eb718c8eb9d9.ajax_pagination_infinite_stop="";block_td_uid_5_5eb718c8eb9d9.max_num_pages="1669";tdBlocksArray.push(block_td_uid_5_5eb718c8eb9d9);</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Featured Articles</span></h4></div><div id=td_uid_5_5eb718c8eb9d9 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_4 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://fanfest.com/fan-fest-exclusive-sam-trammell-talks-homeland/" rel="bookmark" class="td-image-wrap" title="Fan Fest Exclusive: Sam Trammell talks &#8216;Homeland&#8217;"><img width="324" height="235" class="entry-thumb" src="http://fanfest.com/wp-content/uploads/2020/04/xsam_trammell_credit_laura_ise-324x235.jpeg.pagespeed.ic.bAtU0DYpz8.jpg" alt="" title="Fan Fest Exclusive: Sam Trammell talks &#8216;Homeland&#8217;" /></a></div> <a href="http://fanfest.com/category/interviews/" class="td-post-category">Interviews</a> </div>
<h3 class="entry-title td-module-title"><a href="http://fanfest.com/fan-fest-exclusive-sam-trammell-talks-homeland/" rel="bookmark" title="Fan Fest Exclusive: Sam Trammell talks &#8216;Homeland&#8217;">Fan Fest Exclusive: Sam Trammell talks &#8216;Homeland&#8217;</a></h3>
<div class="td-module-meta-info">
<span class="td-post-author-name"><a href="http://fanfest.com/author/beth/">Beth Shiller</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-04-25T12:00:12+00:00">April 25, 2020</time></span> <div class="td-module-comments"><a href="http://fanfest.com/fan-fest-exclusive-sam-trammell-talks-homeland/#respond">0</a></div> </div>
<div class="td-excerpt">
Can you believe that the series finale of Homeland airs tomorrow night? Neither can Sam Trammell who plays VP President Ben Hayes. I recently... </div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://fanfest.com/the-walking-dead-behind-the-scenes-what-comes-next/" rel="bookmark" class="td-image-wrap" title="The Walking Dead: Behind The Scenes &#038; What Comes Next"><img width="100" height="70" class="entry-thumb" src="http://fanfest.com/wp-content/uploads/2020/04/xScreen-Shot-2020-04-14-at-10.55.42-AM-100x70.png.pagespeed.ic.InXGKEi5WU.jpg" srcset="http://fanfest.com/wp-content/uploads/2020/04/xScreen-Shot-2020-04-14-at-10.55.42-AM-100x70.png.pagespeed.ic.InXGKEi5WU.jpg 100w, http://fanfest.com/wp-content/uploads/2020/04/xScreen-Shot-2020-04-14-at-10.55.42-AM-218x150.png.pagespeed.ic.JutKzcfat0.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="The Walking Dead: Behind The Scenes &#038; What Comes Next" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://fanfest.com/the-walking-dead-behind-the-scenes-what-comes-next/" rel="bookmark" title="The Walking Dead: Behind The Scenes &#038; What Comes Next">The Walking Dead: Behind The Scenes &#038; What Comes Next</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-04-14T11:01:17+00:00">April 14, 2020</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://fanfest.com/the-walking-dead-maggies-return-first-image-season-finale-teasers/" rel="bookmark" class="td-image-wrap" title="The Walking Dead: Maggie&#8217;s Return, First Image, Season Finale Teasers"><img width="100" height="70" class="entry-thumb" src="http://fanfest.com/wp-content/uploads/2020/04/xScreen-Shot-2020-04-13-at-1.21.18-PM-100x70.png.pagespeed.ic.j3XoPJCxXH.jpg" srcset="http://fanfest.com/wp-content/uploads/2020/04/xScreen-Shot-2020-04-13-at-1.21.18-PM-100x70.png.pagespeed.ic.j3XoPJCxXH.jpg 100w, http://fanfest.com/wp-content/uploads/2020/04/xScreen-Shot-2020-04-13-at-1.21.18-PM-218x150.png.pagespeed.ic.e2BA5ohZh1.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="The Walking Dead: Maggie&#8217;s Return, First Image, Season Finale Teasers" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://fanfest.com/the-walking-dead-maggies-return-first-image-season-finale-teasers/" rel="bookmark" title="The Walking Dead: Maggie&#8217;s Return, First Image, Season Finale Teasers">The Walking Dead: Maggie&#8217;s Return, First Image, Season Finale Teasers</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-04-13T13:32:14+00:00">April 13, 2020</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://fanfest.com/star-wars-finns-stormtrooper-name-is-an-easter-egg-from-original-film/" rel="bookmark" class="td-image-wrap" title="Star Wars: Finn&#8217;s Stormtrooper Name Is an Easter Egg From Original Film"><img width="100" height="56" class="entry-thumb" src="http://fanfest.com/wp-content/uploads/2018/03/100x56xfinn-main_952e10d2.jpeg.pagespeed.ic.0-e2xiTZRS.jpg" srcset="http://fanfest.com/wp-content/uploads/2018/03/xfinn-main_952e10d2.jpeg.pagespeed.ic.sLuguY7y4I.jpg 1200w, http://fanfest.com/wp-content/uploads/2018/03/finn-main_952e10d2-300x169.jpeg.pagespeed.ce.LQhJ0vZN48.jpg 300w, http://fanfest.com/wp-content/uploads/2018/03/xfinn-main_952e10d2-768x432.jpeg.pagespeed.ic.c2TbyqQAHB.jpg 768w, http://fanfest.com/wp-content/uploads/2018/03/xfinn-main_952e10d2-1024x576.jpeg.pagespeed.ic.R3_N5rqxm7.jpg 1024w, http://fanfest.com/wp-content/uploads/2018/03/xfinn-main_952e10d2-1000x550.jpeg.pagespeed.ic.6kWtItwA3G.jpg 1000w" sizes="(max-width: 100px) 100vw, 100px" alt="John Boyega, Star Wars, Finn" title="Star Wars: Finn&#8217;s Stormtrooper Name Is an Easter Egg From Original Film" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://fanfest.com/star-wars-finns-stormtrooper-name-is-an-easter-egg-from-original-film/" rel="bookmark" title="Star Wars: Finn&#8217;s Stormtrooper Name Is an Easter Egg From Original Film">Star Wars: Finn&#8217;s Stormtrooper Name Is an Easter Egg From Original...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-04-13T13:15:30+00:00">April 13, 2020</time></span> </div>
</div>
</div>
</div> </div></div>  </div>
</div>
</div> 
</div> 
</div> 


<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-3 ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span4">
<div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://fanfest.com/"><img src="http://52.206.29.228/wp-content/uploads/2018/10/Fan-Fest-NEWS-logo_3.png" alt="" title="" /></a></div><div class="footer-text-wrap">For fans, by fans. That is our motto! From the beginning, our goal has been to create a true fan experience. Whether it’s latest reviews, news, and industry scoop at FanFest.com, we want to give fans new ways to interact with the show and characters they love.<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#3851565e57780d0a160a080e160a01160a0a00"><span class="__cf_email__" data-cfemail="0a63646c654a3f3824383a3c24383324383832">[email&#160;protected]</span></a></div></div><div class="footer-social-wrap td-social-style-2">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/FanFestNews" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/fanfestnews/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/FanFestNews" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div></div> </div>
<div class="td-pb-span4">
</div>
<div class="td-pb-span4">
</div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
</div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Fan Fest and the Fan Fest logo are trademarks of Fan Fest News, LLC. All contents of this website are ©2019 by Fan Fest News, LLC. All worldwide rights reserved. Third party images are used under the fair use doctrine. All information and materials on this website are provided for general information and entertainment purposes only. FanFest.com is not associated with—and we have no "official" relationship with—any production company, film or television studio, or any subsidiary or affiliate of the same. The goals of FanFest.com are to provide quality entertainment and useful, interesting information. Questions? Contact: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="791c1d100d160b394c4b574b494f574b40574b4b41">[email&#160;protected]</a> </div>
</div>
</div>
</div>
</div>
<div id="amzn-assoc-ad-6289a9fb-a597-45a9-8538-80b44c9d1dad"></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=6289a9fb-a597-45a9-8538-80b44c9d1dad"></script>

<script src="http://fanfest.com/wp-content,_plugins,_bingo-ruby-core,_assets,_script.js,qver==1.6+wp-includes,_js,_underscore.min.js,qver==1.8.3+wp-content,_plugins,_td-cloud-library,_assets,_js,_js_posts_autoload.min.js,qver==388b2d8ea1192f4a22a4fef9c5911ef0.pagespeed.jc.ebmhVmLBXD.js"></script><script>eval(mod_pagespeed_Hjsb1rsQUe);</script>
<script>eval(mod_pagespeed_JMT55iCIec);</script>
<script>eval(mod_pagespeed_hFuCiHK7k_);</script>
<script type='text/javascript' src='http://fanfest.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js,qver=9.7.4.pagespeed.jm.EB6FryVt28.js'></script>
<script src="http://fanfest.com/wp-includes,_js,_comment-reply.min.js,qver==5.3.3+wp-content,_plugins,_td-cloud-library,_assets,_js,_js_files_for_front.min.js,qver==388b2d8ea1192f4a22a4fef9c5911ef0+wp-includes,_js,_wp-embed.min.js,qver==5.3.3.pagespeed.jc._XwaOVjMJ1.js"></script><script>eval(mod_pagespeed_GL2RYDdq6W);</script>
<script>eval(mod_pagespeed_jbQg97XAHm);</script>
<script>eval(mod_pagespeed_zfOnnqpK92);</script>
<script async="async" type='text/javascript'>//<![CDATA[
var ak_js=document.getElementById("ak_js");if(!ak_js){ak_js=document.createElement('input');ak_js.setAttribute('id','ak_js');ak_js.setAttribute('name','ak_js');ak_js.setAttribute('type','hidden');}else{ak_js.parentNode.removeChild(ak_js);}ak_js.setAttribute('value',(new Date()).getTime());var commentForm=document.getElementById('commentform');if(commentForm){commentForm.appendChild(ak_js);}else{var replyRowContainer=document.getElementById('replyrow');if(replyRowContainer){var children=replyRowContainer.getElementsByTagName('td');if(children.length>0){children[0].appendChild(ak_js);}}}
//]]></script>

<script></script>
</body>
</html>